Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Instant Sites are not loading
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jun 30, 2020 - 08:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2020 - 07:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 30, 2020 - 07:53 UTC
Investigating
We are having issues with all of Ecwid Instant Sites — they are not loading. We’re working on it urgently and will keep you posted here.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The Instant Sites will be up and running as usual once the issue is fixed.

We are sorry for this downtime. We'll post the next update in 15 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Jun 30, 2020 - 07:37 UTC
This incident affected: Storefront.