Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Instant Sites and Control Panels are not loading

Incident Report for Ecwid

Resolved

We are glad to inform you that the issue has been fixed - Ecwid Instant Sites and Control Panels are now loading and functioning as usual. All the data (products, orders, your store settings, etc) are safe and intact. We are deeply sorry for the experience.
Posted May 08, 2025 - 14:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2025 - 13:52 UTC

Identified

We found the root cause of the incident on our end. We're fixing it right now.
Posted May 08, 2025 - 13:33 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2025 - 13:03 UTC

Update

At the moment, we have no news about the issue, we are very sorry. The developers are urgently investigating the issue further.
Posted May 08, 2025 - 12:47 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2025 - 12:28 UTC

Investigating

We are having issues with Ecwid Instant Sites and Control Panels — they are not loading. We’re working on it urgently and will keep you posted here.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The Instant Sites and your Control Panel will be up and running as usual once the issue is fixed.

We are sorry for this downtime.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted May 08, 2025 - 12:16 UTC
This incident affected: Storefront, Admin, and API.