Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Orders are not displayed in the Control Panels
Incident Report for Ecwid
Resolved
We have restored the service. Please accept our sincere apologies for this downtime.
Posted May 16, 2020 - 15:55 UTC
Update
We are still investigating this issue.
Posted May 16, 2020 - 15:26 UTC
Update
We are continuing to investigate the issue.
Posted May 16, 2020 - 14:26 UTC
Investigating
At this moment orders aren’t displayed in the “My sales” section in the Control Panels. The stores and checkout pages are well-operating, so you should be getting new orders as usual. It is just that you can’t view them in the Control Panel.

We are urgently looking into this. In the meantime, you can check for order details in the email notifications. When a customer places an order, you will receive an email with the order details.

We are sorry for this issue.
All orders will be displayed back under “My Sales”. The next update is in 15 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com . Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted May 16, 2020 - 13:50 UTC
This incident affected: Admin.