Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some orders may disappear from the Control Panels
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 15:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2020 - 15:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 24, 2020 - 15:10 UTC
Update
We are continuing to investigate this issue.
Posted Jul 24, 2020 - 14:36 UTC
Update
We are still investigating the issue. The next update is in 30 minutes.
Posted Jul 24, 2020 - 14:26 UTC
Investigating
At this moment some orders placed in the stores may not be displayed in the “My sales” section in the Control Panels. The stores and checkout pages are well-operating, so you should be getting new orders as usual. It is just that you can’t view them in the Control Panel.

We are urgently looking into this. In the meantime, you can check for order details in the email notifications. When a customer places an order, you will receive an email with the order details.

All orders will be displayed back under “My Sales”. We are sorry for this issue!

The next update is in 15 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com . Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Jul 24, 2020 - 14:03 UTC
This incident affected: Admin.