Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Upgrading to a paid plan from iOS mobile app using iTunes
Incident Report for Ecwid
Resolved
Apple fixed the issue with iTunes subscriptions. We've taken steps to make sure your Ecwid stores were not affected by this incident.
Posted Jan 24, 2020 - 20:25 UTC
Investigating
This message is for the Ecwid account owners who are trying to upgrade from the Free plan to any paid plan from iOS Ecwid mobile app (using iTunes). If your Ecwid store is already on a paid plan, you can safely ignore this message.

Apple is having issues with iTunes subscriptions (https://www.apple.com/support/systemstatus/), so if you are trying to upgrade to a paid Ecwid plan using your iOS Ecwid mobile app, the subscription may not apply and as a result, your account may stay on the Free plan even though the payment went through.

We are looking into this now and we will be posting updates here.
This issue does not affect your Ecwid storefronts and control panels: all your info is safe and intact, customers can place orders and you can process them normally.

If you have any questions, just drop us a line at support@ecwid.com
Posted Jan 24, 2020 - 16:58 UTC
This incident affected: Billing.