PayPal is experiencing issue with the payment processing
Incident Report for Ecwid
Resolved
PayPal has fixed the issue on their side. PayPal payments should be operational.
Posted Jul 02, 2020 - 22:04 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 02, 2020 - 22:03 UTC
Monitoring
Currently, PayPal is experiencing a system issue that may be affecting the ability for customers to pay for orders. We will send an update with additional details as they become available.

The status concerns Ecwid store owners who are using PayPal to receive payments. Your customers will still be able to pay using other payment methods.

To see the latest status of PayPal issue, please visit the official PayPal status page: https://www.paypal-status.com/history/production
(PP-LIVE-14157)

Please Note: the issue with PayPal does not affect your store data like orders, products, customers, etc. All your data is safe.

Your storefront is totally available, your customers are able to view products and add them to the shopping cart and pay using other payments.
Posted Jul 02, 2020 - 21:45 UTC
This incident affected: Checkout.