Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

New orders appear in the Ecwid Control Panels with a delay
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 00:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2020 - 00:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 24, 2020 - 00:09 UTC
Update
We are very sorry for this issue. We are continuing to investigate it.
The next update will be in about 40 minutes.
Posted Jun 23, 2020 - 23:17 UTC
Update
We are continuing to investigate this issue.
Please, note: all your data is safe and intact.
Posted Jun 23, 2020 - 22:22 UTC
Investigating
Currently, we're experiencing the orders' queue growth in the system which might cause the orders appearing in the Ecwid Control Panels with a delay. The stores and checkout pages are well-operating, so you should be getting new orders as usual. It is just that you can’t view them in the Control Panel.

We are urgently looking into this. In the meantime, you can check for order details in the email notifications. When a customer places an order, you will receive an email with the order details. Make sure, you have the 'New Order Placed' notification enabled in your Ecwid Control Panel > Settings > Mail.

We are sorry for this issue.
All orders will be displayed back under “My Sales”. The next update is in 15 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com . Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Jun 23, 2020 - 21:54 UTC
This incident affected: Admin.