Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some Ecwid admin backends are not available for login
Incident Report for Ecwid
Resolved
The problem with some admin back ends being unavailable for login has been resolved. The starter sites are available too.
Please accept our apologies for the troubles. All data in the stores is kept safe and intact.
Posted Nov 29, 2016 - 12:22 UTC
Investigating
At the moment some of Ecwid admin back ends (Control Panels) are not available for login. Starter sites may not be visible too. Our development team has found the source of this issue and is in the process of restoring the service.

The estimated time of restoration is about 20 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Nov 29, 2016 - 12:08 UTC