Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Dashboards are loading slowly for some US store owners
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 23:13 UTC
Update
We are continuing to monitor the fix for any further issues.
Posted Mar 20, 2020 - 22:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2020 - 20:31 UTC
Identified
The fix is still on the way. At the moment, we need some more time to implement it.

ETA is 20 min.
Posted Mar 20, 2020 - 20:17 UTC
Update
We are working on the fix.

ETA is 15 min.
Posted Mar 20, 2020 - 20:01 UTC
Update
We are continuing to investigate this issue.

Next update will be in 15 min.
Posted Mar 20, 2020 - 19:41 UTC
Investigating
We are experiencing an issue with one of the servers — Ecwid Dashboards load slowly or don't load at all for some US store owners. You may see 'We are having technical issues' error.

We are urgently looking into the issue.

All your data (products, orders, customer details, store settings, etc) is safe and intact. Ecwid Dashboards will be up when the issue is fixed.

We are sorry for this downtime. The approximate time of when the issue is resolved is in 30 minutes. The next update is in 15 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Mar 20, 2020 - 19:20 UTC
This incident affected: Admin.