Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Dashboards are loading slowly
Incident Report for Ecwid
Resolved
The incident has been resolved.

Starting from Oct 07, 2021 - 18:30 UTC all services have been operating without interruption.

We're glad to let you know that all Ecwid storefronts and dashboards are now fully operational.

All your data is safe and intact. Customers can place orders normally.
Posted Oct 07, 2021 - 20:02 UTC
Monitoring
We've restored the service and now we are monitoring the results.
Posted Oct 07, 2021 - 19:03 UTC
Update
We are still continuing to investigate this issue.
Posted Oct 07, 2021 - 18:28 UTC
Update
We are continuing to investigate this issue.
Posted Oct 07, 2021 - 17:50 UTC
Investigating
We are experiencing an issue with one of the servers — Ecwid Dashboards and stores load slowly or don't load at all. You may see 'We are having technical issues' error.

We are urgently looking into the issue.

All your data (products, orders, customer details, store settings, etc) is safe and intact. Ecwid Dashboards and stores will be up when the issue is fixed.

We are sorry for this downtime. The next update is in 20 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Oct 07, 2021 - 17:45 UTC
This incident affected: Storefront, Admin, and API.