Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid main websites (ecwid.com and ecwid.ru), and Forum are unavailable.
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue with our websites has been completely fixed.
Posted May 15, 2020 - 14:06 UTC
Monitoring
The Ecwid websites are up and running now. We continue to monitor the systems to ensure that everything works smoothly.
Posted May 15, 2020 - 12:42 UTC
Investigating
We are having issues with main Ecwid websites and Forum: www.ecwid.com, www.ecwid.ru, www.ecwid.com/forums are unavailable for visitors. We are working to bring sites back into service.

The issue affects only Ecwid websites (www.ecwid.com, www.ecwid.ru, www.ecwid.com/forums), it has no impact on users' shops and their data.

We are sorry for this downtime.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted May 15, 2020 - 11:59 UTC