Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Order page and images are loading slowly
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been fixed. All the data (products, orders, your store settings, etc) are safe and intact. The product images and Ecwid Order page continue functioning as usual. We are deeply sorry for the bad experience. We’ll do better.
Posted Jul 22, 2020 - 14:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2020 - 13:46 UTC
Identified
We've identified a cause of the issue and are restoring the service. The approximate time of when the issue is resolved is in 40 minutes. We’ll keep you updated here!
Posted Jul 22, 2020 - 12:50 UTC
Update
We continue investigating the issue. The next update is in 60 minutes.
Posted Jul 22, 2020 - 11:20 UTC
Investigating
We are experiencing an issue — Ecwid Order page in Ecwid admin and product images load slowly or don't load at all.

We are urgently looking into the issue.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The Ecwid Order page and product images will be up when the issue is fixed.

We are sorry for this downtime. The next update is in 40 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Jul 22, 2020 - 10:43 UTC
This incident affected: Storefront and Admin.