Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some storefronts may have a constantly spinning wheel
Incident Report for Ecwid
Resolved
We have restored the service, all Ecwid stores are now up and running. We continue investigating this incident to find out what led to such a problem.
Posted Sep 09, 2022 - 19:30 UTC
Update
We have managed to detect the cause of the downtime and are working on a fix right now.
Posted Sep 09, 2022 - 16:38 UTC
Investigating
One of our servers is having problems since 2022.09.09, 15:00 UTC. This causes around 21.5% of storefronts. You may see a constantly spinning wheel if you're in this coverage.
We are working on restoring the service. All your data and store settings will be intact.
We are sorry for this downtime. Next update in 30 minutes.
Posted Sep 09, 2022 - 15:56 UTC
This incident affected: Admin.