Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and control panels are unavailable
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been fixed. All the data (products, orders, your store settings, etc) are safe and intact. The Ecwid stores continue functioning as usual.
Posted Jun 26, 2020 - 22:28 UTC
Monitoring
Our developers have released a fix, and all Ecwid servers are up and running again. We are monitoring the results now.
Posted Jun 26, 2020 - 20:01 UTC
Update
We are continuing to investigate this issue.
Posted Jun 26, 2020 - 19:34 UTC
Investigating
Ecwid control panels and storefronts are not loading or are loading slowly for some users. You may see the 'We are having technical issues' error in your control panel, and your customers cannot access your store with "This page isn’t working" error.

We are urgently working on a fix.

All your data (products, orders, customer details, store settings, etc.) is safe and intact. The storefronts and control panels will be up and running once we fix the problem.

We are very sorry for this downtime. We'll be posting updates here.

If you have any questions, you can email our Support team at support@ecwid.com, or start a chat at ecwid.com or in the mobile app.
Posted Jun 26, 2020 - 19:24 UTC
This incident affected: Storefront, Checkout, Admin, and Billing.