Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Square payment service doesn’t work
Incident Report for Ecwid
Resolved
The Square team has resolved the issue based on their Status page. You should now be able to accept online payments with this gateway in your store.
Posted Sep 08, 2023 - 09:56 UTC
Investigating
This message is for Ecwid store owners who use Square for accepting online card payments in their online stores.

Square is experiencing a service disruption.
Your customers may see a frozen page when they click on the "Pay" button on your site.

We are on it and urgently looking for a fix. All your data (products, orders, customer details, store settings, etc) is safe and intact. The Square payment button will be well-functioning when the fix is released by the Square team.

If you’re using other payment methods (together with Square), your storefront displays the “Checkout” button and your customers are able to checkout and pay.

In case Square is the only payment option, customers are unable to proceed to checkout. You can use the following workaround:

1. Disable Square in your Ecwid Control Panel > Payment ;
2. If possible, enable any other payment methods available in your country: https://support.ecwid.com/hc/en-us/articles/360003449720-Payment-options-by-countries
3. You can send manual invoices to the customers:

3.1 Add a manual (offline) payment method ( Instructions ), named e.g. “Invoice”.
3.2 Once you receive an order, you can email the customer and attach the invoice.

We are sorry for this downtime. We're monitoring the situation with Square status page at https://www.issquareup.com/

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Sep 07, 2023 - 19:44 UTC
This incident affected: Checkout.