Ecwid control panels are unavailable for 28% of users
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 11:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2020 - 11:09 UTC
Investigating
Ecwid control panels are not loading or are loading slowly for 28% of users:
You may see the 'We are having technical issues' error in your control panel.

We are urgently working on a fix.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts and control panels will be up and running once we fix the problem.

We are very sorry for this downtime. We’ll be posting updates here.

If you have any questions, you can email our Support team at support@ecwid.com, or start Pre-Sales Chat: click on the chat icon on our site https://www.ecwid.com/ ( Screenshot)
Posted Mar 16, 2020 - 10:53 UTC
This incident affected: Control Panel.