Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Outage of USPS Shipping Services
Incident Report for Ecwid
Resolved
USPS resolved their issue with the API and USPS shipping methods work correctly in Ecwid stores.

For more details and USPS outage history please visit:
http://www.shippingapimonitor.com/history.html?api=usps
Posted Jun 15, 2020 - 03:02 UTC
Investigating
We are experiencing an issue with USPS shipping method to receive shipping rates online in your store.
Please refer to USPS Status Page: https://www.shippingapimonitor.com/history.html?api=usps

Customers using USPS may be unable to get the live rates and track orders.

Your customers might see the error “We do not ship to this location”, or USPS shipping method will not be shown on the checkout page.

Please note the storefront will be totally available, your customers can browse your catalog and add items to the shopping cart. To make sure your customers can complete their orders, we suggest the following alternatives until the scheduled maintenance is over:

- You can disable USPS method temporarily
- Create a Flat Rate shipping method or a Custom Table to ensure your customers will receive proper shipping rates. See the instructions in our article here:

- Flat Rates: https://support.ecwid.com/hc/en-us/articles/360000030940-Flat-rates
- Custom Table: https://support.ecwid.com/hc/en-us/articles/360000031040-Custom-rates-based-on-subtotal-or-weight-

All your data (products, orders, customer details, store settings, etc) is safe and intact, the USPS will be operating normally as soon as the issue is fixed.
Posted Jun 14, 2020 - 09:23 UTC
This incident affected: Checkout.