Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Order Confirmation email notifications are not reaching customers
Incident Report for Ecwid
Resolved
The issue has been fixed.

We are deeply sorry for the bad experience.
Posted Jun 04, 2020 - 01:08 UTC
Monitoring
We identified a cause of the issue and applied a fix to it. All email notifications should be sent as usual. You should get unreceived email notifications soon as well.

We continue to monitor the systems to ensure that everything works smoothly.
Posted Jun 03, 2020 - 22:14 UTC
Update
We are still investigating what causes the problem with the email notifications. The problem is reproducing not only with the Order Confirmation emails that customers receive but also, with the New Order Placed emails that are sent to the store owners.
The next update is in 45 minutes.
Posted Jun 03, 2020 - 20:49 UTC
Investigating
We are experiencing an issue that relates to the order confirmation emails. The emails are not sent if customers place orders. As a result, they do not receive order confirmation emails when their orders are placed.

We are working to bring order confirmation emails back into service. All your data (products, orders, customer details, store settings, etc) is safe and intact.

We’re urgently working on resolving the problem.
We are sorry for this downtime. The next update is in 45 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat (Screenshot https://ecwid.d.pr/36d9nh).
Posted Jun 03, 2020 - 19:34 UTC