Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some Instant Sites and website editors don't load

Incident Report for Ecwid

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 11:04 UTC

Monitoring

A fix has been implemented. Instant Sites and website editors are loading now. We'll be monitoring the issue further.
Posted Jun 02, 2025 - 10:26 UTC

Identified

An issue with Instant Site website display was identified. Our team is working on an urgent fix for it.
Posted Jun 02, 2025 - 10:04 UTC

Investigating

We're experiencing issues on our servers, which are causing some Instant Site websites and website editors to show a blank screen instead of website content. Ecwid admin panels load normally and store data (products, customers, settings) should stay intact. Please accept our apologies.

We are actively investigating the issue.
Posted Jun 02, 2025 - 09:48 UTC
This incident affected: Storefront.