Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Can't print purchased shipping labels from Ecwid Admin
Incident Report for Ecwid
Resolved
This incident has been resolved.

Store owners can print shipping labels bought through Ecwid Admin without any issues.

We're sorry for all the troubles!
Posted May 03, 2022 - 10:06 UTC
Monitoring
Right now, store owners can print shipping labels bought through Ecwid Admin without any issues. The issue was in the process of updating Ecwid data for our shipping label services.
We will continue monitor this process and will let you know if we get any updates on the matter.
Posted May 03, 2022 - 07:05 UTC
Update
We are continuing to investigate this issue and we are in contact with our shipping label services. Meanwhile, please purchase the label directly from the USPS shipping carrier via the direct link https://www.usps.com/business/postage-options.htm.
Posted May 03, 2022 - 05:58 UTC
Update
We keep looking for the cause of the issue and in contact with our shipping label services. Once we know more from them, we’ll post an update. The shipping label feature will be temporarily disabled until we fix it.
Please, purchase the label directly from the USPS shipping carrier via the direct link https://www.usps.com/business/postage-options.htm.
We are deeply sorry for the bad experience.
Posted May 03, 2022 - 03:16 UTC
Update
We are continuing to investigate this issue. Meanwhile, please purchase the label directly from the USPS shipping carrier via the direct link https://www.usps.com/business/postage-options.htm.
Next update will be posted in 30 minutes.
Posted May 03, 2022 - 02:22 UTC
Update
We are continuing to investigate this issue.
Posted May 03, 2022 - 01:51 UTC
Investigating
We are experiencing an issue with services, which provides shipping label functionality to us.

At this moment, store owners can't print shipping labels bought trough Ecwid Admin.
All your data (products, orders, customer details, store settings, etc) is safe and intact.
While we’re on it, please purchase the label directly from a shipping carrier, until we fix the issue.

We are sorry for this downtime. The next update is in 30 minutes.

If you have any questions, you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat.
Posted May 03, 2022 - 01:50 UTC
This incident affected: Third-party services.