Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and Control Panels are not available for some users
Incident Report for Ecwid
Resolved
Our engineers have fixed the problem: all Ecwid storefronts and Control panels are loading fine now.

We are really sorry for the temporary downtime.
Posted May 18, 2017 - 13:55 UTC
Investigating
Ecwid storefronts and Control Panels are not available for some of users

At the moment some Ecwid storefronts and Control Panels are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is ten minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted May 18, 2017 - 13:44 UTC