Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Degraded performance of websites built on Weebly
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 10:39 UTC
Monitoring
Weebly Team has implemented fix. Now Weebly websites are working fine. We will keep monitoring the situation with Weebly websites.
Posted Feb 19, 2020 - 08:43 UTC
Investigating
Websites built on Weebly might face performance issues.

The issue is on Weebly side and their Team is working on the resolution.

As for your Ecwid Stores:

All your data (products, orders, customer details, store settings, etc) is safe and intact. Your Ecwid Instant Sites are up and running.
Posted Feb 19, 2020 - 07:24 UTC