Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Instant Sites are unavailable for 100% users
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Sep 29, 2019 - 08:00 UTC
Monitoring
Our developers implemented the fix. We continue to monitor this issue.
Posted Sep 29, 2019 - 01:04 UTC
Investigating
At the moment, all the Ecwid Instant Sites are unavailable for 100% users.

All your data (products, orders, customer details, store settings, etc) is safe and intact, the Instant Sites will be operating normally as soon as the issue is fixed.

We are sorry for this downtime. Next update on the issue in 20 minutes.
Posted Sep 29, 2019 - 00:55 UTC
This incident affected: Storefront and Checkout.