Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Login issues due to Google authentication outage
Incident Report for Ecwid
Resolved
Google reports, that all services are available. The incident has been resolved.
Posted Aug 19, 2019 - 21:01 UTC
Identified
The problem has been identified and the mitigation work is underway by Google team. The performance of the authentication service is improving.

Google Team has also reported that some users were able to log in using an incognito window under the Chrome browser. Here's how to switch your browser to the Incognito mode in Chrome: https://support.google.com/chrome/answer/95464

NOTE: You are still able to login to your Ecwid dashboard at https://my.ecwid.com by typing in your login and password. You can also manage your store via our mobile apps on iOS or Android.

Further updates to follow.
Posted Aug 19, 2019 - 19:50 UTC
Update
Google Team is reporting that some users were able to log in using an incognito window under the Chrome browser. Here's how to switch your browser to the Incognito mode in Chrome: https://support.google.com/chrome/answer/95464

The investigation is ongoing and the next update will be provided by 12:45 US/Pacific (as Google reports). We will post their updates here as they come.
Posted Aug 19, 2019 - 19:37 UTC
Investigating
Right now Google Cloud Console is experiencing issues with authentication. That means, that no merchant is able to login into the Ecwid dashboard via their Google authorization. The problem started to affect users at 2019-08-19 11:30 (US/Pacific). Here's the link to the Google status page and this incident in particular: https://status.cloud.google.com/incident/developers-console/19008

Google is trying to fix the issue on their side at this very moment. Further updates to follow.

NOTE: You are still able to login to your Ecwid dashboard at https://my.ecwid.com by typing in your login and password. You can also manage your store via our mobile apps on iOS or Android.
Posted Aug 19, 2019 - 19:20 UTC
This incident affected: Admin.