We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com
We are continuing to work on a fix for this issue.
Posted Jan 15, 2025 - 02:49 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 14, 2025 - 23:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 14, 2025 - 21:44 UTC
Investigating
Ecwid storefronts may reflect product changes with a delay. When you assign a product to a category in the backend this change can reflect on the live site not momentarily.
Issue may affect 22% of store owners. We are working on the fix urgently.
All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts will be operating normally as soon as the issue is fixed.
We are sorry this is affecting your normal workflow. The next update is in one hour.
If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).