Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid dashboards and storefronts are unavailable
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 14:45 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 31, 2020 - 13:57 UTC
Monitoring
Our developers have released a fix, and we are monitoring the results.
Posted Jan 31, 2020 - 10:31 UTC
Investigating
Ecwid control panels and storefronts experience loading issues at the moment: you may see the 'We are having technical issues' error in your control panel as well as on the storefront. The issue affects Russian users mostly.

We are urgently working on a fix. All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts and control panels will be up and running once we fix the problem.

We are very sorry for this downtime. We’ll be posting updates here.

If you have any questions, you can email our Support team at support@ecwid.com.
Posted Jan 31, 2020 - 09:34 UTC
This incident affected: Admin.