Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some Ecwid Control panels and online stores are loading slowly
Incident Report for Ecwid
Resolved
The incident with slow loading has been resolved.
Posted Aug 06, 2019 - 22:57 UTC
Update
Our developers implemented the fix. Ecwid Control Panels and Stores work as normal again. We continue to monitor this issue.
Posted Aug 06, 2019 - 19:39 UTC
Monitoring
Our developers implemented the fix. Ecwid Control Panels and Stores work as normal again. We continue to monitor this issue.

Please accept our sincere apologies
Posted Aug 06, 2019 - 19:01 UTC
Investigating
Some Ecwid Control panels and online stores are loading slowly

Our developers are already aware of the issue, we are looking into it now.

Please accept our sincere apologies. All your store data will be kept intact, and we will be posting updates here.
Posted Aug 06, 2019 - 18:38 UTC
This incident affected: Storefront and Admin.