Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

European stores only: some email notifications are not being delivered to customers and store owners
Incident Report for Ecwid
Resolved
The incident was resolved.

We restored the service and all the delayed email notifications are being sent to store owners and customers now.

All future email notifications will be sent normally.

Please, forgive us for any difficulties this issue caused.
Posted Oct 08, 2021 - 11:17 UTC
Investigating
2021.10.07 , 16:50 UTC (lhttp://www.worldtimebuddy.com)

Some New Order Placed notifications, Order Confirmations, copies of customers Orders confirmation emails, and ‘Files ready for download’ emails are not being sent to store owners and customers in Ecwid stores located in Europe.

We are urgently working on fixing the issue. We will give you the next update here in 1 hour.

All store data is intact. You can download the Ecwid app on mobile devices to receive notifications about new orders or check new orders in Ecwid Admin > My Sales > Orders.

Impact: Ecwid stores located in Europe

Please, accept our apologies.
Posted Oct 08, 2021 - 07:58 UTC
This incident affected: Admin.