Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are unavailable on Wix websites
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Oct 01, 2019 - 07:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 01, 2019 - 06:38 UTC
Investigating
Ecwid storefronts are not loading on Wix websites. When you open your storefront page, you can see "Service is temporarily unavailable. Please try again later" error.

We are working to get them up and running urgently.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts will be operating well as soon as the issue is fixed.

We are sorry for this downtime.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat.
Posted Oct 01, 2019 - 05:46 UTC
This incident affected: Storefront.