Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

27% of Ecwid storefronts and control panels are unavailable
Incident Report for Ecwid
Resolved
We have restored the service. Please accept our sincere apologies for this downtime.
Posted May 16, 2020 - 15:55 UTC
Identified
Some Ecwid control panels may still load slowly. Also, there may be "Sorry, we're experiencing technical difficulties" error.
Posted May 16, 2020 - 15:28 UTC
Monitoring
We've implemented the fix for the issue and now Ecwid storefronts and control panels load fine.

We're monitoring the results and continuing to investigate the issue.
Posted May 16, 2020 - 13:34 UTC
Investigating
27% of Ecwid control panels and storefronts are not loading or are loading slowly:
You may see the 'We are having technical issues' error in your control panel.
And your customers can not access your store.

We are urgently working on a fix.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts and control panels will be up and running once we fix the problem.

We are very sorry for this downtime. The approximate time of when the issue is resolved is in 15 minutes. We’ll be posting updates here.

If you have any questions, you can email our Support team at support@ecwid.com, or start Pre-Sales Chat: click on the chat icon on our site https://www.ecwid.com/ ( Screenshot)
Posted May 16, 2020 - 13:17 UTC
This incident affected: Storefront and Admin.