Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid instant sites are not available for 100% users
Incident Report for Ecwid
Resolved
This incident has been resolved.

Ecwid instant sites are up and running and all store data including products, orders, customers, settings are safe and intact.

Please accept our sincere apologies for this issue.
Posted Aug 17, 2019 - 19:43 UTC
Monitoring
We've restored the service.

We'll be monitoring the availability of Ecwid instant sites to make sure this problem won't occur again.
Posted Aug 17, 2019 - 19:31 UTC
Investigating
This status concerns the merchants who use Ecwid instant sites (also known as Ecwid starter sites). Ecwid stores embedded into websites and social networks work fine.

Ecwid instant sites are experiencing a short downtime at this moment. It means that merchants and customers get "This page isn’t working" error when trying to access Ecwid instant sites.

We are on this problem.

Please accept our sincere apologies for this downtime. All your store data will be kept intact and we will be posting updates here.
Posted Aug 17, 2019 - 19:23 UTC
This incident affected: Storefront.