Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid control panels and storefronts may not load for 27% of users
Incident Report for Ecwid
Resolved
All the servers are restored. Ecwid storefronts and Control Panels are up and running. All the data (products, orders, your store settings, etc) is intact. The Ecwid stores continue functioning as usual.
Posted Oct 01, 2018 - 17:19 UTC
Monitoring
Our development team has found the source of this issue and the service has been restored. We continue monitoring the situation.
Posted Oct 01, 2018 - 17:10 UTC
Investigating
We are experiencing technical issues with some of our servers and some of the Ecwid control panels and storefronts may not load or load slowly. It may affect 27% of the users. Our Engineering team is already aware and they are working on a fix now.

All your data will be kept intact and safe. Please, accept our apologies for this downtime. We will inform you of the progress here.
Posted Oct 01, 2018 - 16:46 UTC
This incident affected: Storefront, Checkout, and Admin.