Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

We do not get emails to some support emails
Incident Report for Ecwid
Resolved
We now receive emails to support@ecwid.com, billing@ecwid.com and customizations@ecwid.com addresses without any issues.

The incident is resolved.

We're sorry for all the troubles!
Posted Jan 15, 2022 - 09:16 UTC
Identified
The support@ecwid.com email is now available and we receive all the new emails to this address.

We're still working on the access to billing@ecwid.com and customizations@ecwid.com addresses. The next update will be posted in 30 minutes.
Posted Jan 15, 2022 - 08:38 UTC
Investigating
Currently some email addresses with @ecwid.com domain are unavailable. The following addresses are affected:
support@ecwid.com
billing@ecwid.com
customizations@ecwid.com

If you send an email at any of these addresses, you will get the 'Message not delivered' reply from our mailing system. We're currently investigating the issue.

All the store data is safe and intact.
Customers are getting notifications from Ecwid stores as usual.

With any questions, please email us at ec.support@lightspeedhq.com or submit a request via our Help Center at the direct link: https://support.ecwid.com/hc/en-us/requests/new

We'll keep you posted for further updates.
Posted Jan 15, 2022 - 07:48 UTC
This incident affected: Storefront, Checkout, Admin, API, Third-party services, and Billing.