Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Issue with checkout page performance and new orders in some US stores
Incident Report for Ecwid
Resolved
This incident has been resolved.

Some users may not see recent orders that were placed in their stores during the incident. This is only a visual issue and orders are saved in our databases.

If that's the case for you, please contact us at ec.support@lightspeedhq.com, so we can make those orders visible in your store manually.
Posted Feb 09, 2024 - 22:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2024 - 22:09 UTC
Investigating
Orders don't appear in Ecwid admin accounts and checkout page loads slowly in 25% of US stores. Although orders are saved in our databases, they're currently hidden on the webpage. Our developers are investigating the issue.
Posted Feb 09, 2024 - 20:19 UTC
This incident affected: Checkout and Admin.