Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Free shipping orders can't be paid for with Square Payments
Incident Report for Ecwid
Resolved
The issue with the payments via Square has been resolved.

The fix is now live. The new orders are being accepted as usual regardless of the state of the “Ask for a billing address during checkout” setting.

We are really sorry about this incident.
Posted Aug 28, 2019 - 16:20 UTC
Update
Our team is still on this issue.

We are continuing to work on the release of the fix. The current ETA is in 40 minutes.

As a quick fix, the orders can still be placed if the setting “Ask for a billing address during checkout” is disabled. To disable it go to your "Control Panel > Settings > Cart & Checkout" page at https://my.ecwid.com/#cart and toggle the switch next to it.

We are really sorry about the delay.
Posted Aug 28, 2019 - 15:19 UTC
Update
The fix to this issue has been developed and is currently being added into Ecwid.

It should go live in approximately 30 min.

An update will posted once it's ready.

We apologize for the delay.
Posted Aug 28, 2019 - 14:16 UTC
Update
Our engineers continue working on a fix.

In the meantime, the orders can still be paid for via Square Payments if the setting “Ask for a billing address during checkout” is disabled.

We are sorry about this issue — it should be fixed very soon.

Next update will be posted in 20 min.
Posted Aug 28, 2019 - 13:53 UTC
Update
Our team is continuing to work on this issue.

As a temporary workaround the orders can be placed at the checkout if the option “Ask for a billing address during checkout” is disabled. This option can be found in your "Control Panel > Settings > Cart & Checkout" page at https://my.ecwid.com/#cart

Next update can be expected in another 20 minutes.
Posted Aug 28, 2019 - 13:29 UTC
Identified
The issue has been identified and our engineers are working on developing a fix. Payments are still accepted correctly for the orders using other payment or shipping methods.

Please note, that all of your store data including previous orders is kept intact. Payments are still accepted correctly for the orders using other payment or shipping methods.

We'll post the next update in 20 min.

We are sorry about this issue.
Posted Aug 28, 2019 - 13:05 UTC
Investigating
We're currently experiencing issues with the payment form for Square Payments. The payments can't be accepted for the orders where the Free shipping method is selected.

Our team is on it.

Next update will be posted in 20 min.

We are sorry for this issue.
Posted Aug 28, 2019 - 12:45 UTC
This incident affected: Checkout.