Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid users are not able to login to the Ecwid Control Panels
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been fixed. All the data (products, orders, your store settings, etc) are safe and intact. We are deeply sorry for the difficulties you faced.
Posted Oct 01, 2019 - 14:56 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 01, 2019 - 14:11 UTC
Monitoring
A fix has been implemented. We continue to monitor the systems to ensure that everything works smoothly.
Posted Oct 01, 2019 - 14:09 UTC
Investigating
When you log in to the Ecwid Control Panel at my.ecwid.com with Google or Facebook, you can see "HTTP Error 500." error.

NOTE: You are still able to login to your Ecwid dashboard at https://my.ecwid.com by typing in your login and password. You can also manage your store via our mobile apps on iOS or Android.

We are urgently working on a fix.

All your data (products, orders, customer details, store settings, etc) is safe and intact.

We are very sorry for this downtime.
Posted Oct 01, 2019 - 10:43 UTC
This incident affected: Admin.