Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

30% of Ecwid storefronts and control panels are unavailable
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jul 14, 2021 - 15:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2021 - 14:45 UTC
Identified
We have identified the issue and are implementing the fix.
Posted Jul 14, 2021 - 14:21 UTC
Update
We continue investigating this issue.
Posted Jul 14, 2021 - 14:18 UTC
Investigating
30% of Ecwid control panels and storefronts were loading slowly.

Our developers found out the reason and fixed the issue. We keep monitoring the situation. Everything should load without any errors.

If you have any questions, you can email our Support team at support@ecwid.com, or start a live chat via this form Contact us
Posted Jul 14, 2021 - 13:53 UTC
This incident affected: Storefront, Admin, and API.