We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com
The issue has been resolved, orders and products are displayed correctly in store. If you notice that some of the products are still missing, please get in touch with us at support@ecwid.com.
Posted May 05, 2025 - 18:04 UTC
Identified
We've identified the root cause of the issue and fixed it, the products and sales should be back in stores. Some orders placed in the past 2 hours might still be missing, we're working on this at the moment and will refresh the data to have all info back in stores.
Posted May 05, 2025 - 15:27 UTC
Investigating
In some of the stores products and orders might be missing. Your data is intact and we're already working on bringing back store data as soon as possible. The stores will be operating normally as soon as the issue is fixed, we're sorry for the issue.
If you have any questions, you can email our Support team at support@ecwid.com.