We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com
Possible delays in products, orders and subscriptions display
We fixed the issue. Products on the storefront and orders in the admin panel are displayed without delay.
Posted Jul 16, 2025 - 14:42 UTC
Identified
We identified the root if the issue and are working on the fix.
Posted Jul 16, 2025 - 13:55 UTC
Investigating
This message concerns 14% Ecwid store owners.
We're experiencing an internal issue. As a result some store owners may experience these types of delays:
1. Some products from your catalog may not be showing on your site 2. New orders may arrive in your Ecwid admin > My Sales > Orders section with a delay. You are receiving email notifications about the new orders in your store with no interruption. 3. Some info from My sales > Subscriptions tab may appear to be missing.
We are urgently working on the fix for you.
All your data (products, orders, customer details, store settings, etc) is safe and intact. All the missing information will be showing up normally once we fix the issue.
We are very sorry for this downtime. We’ll be posting updates here, next update is in one hour.
If you notice that some of the products are missing on your site, please email our Support team at support@ecwid.com, or start live chat from your Ecwid admin > Top right corner > Get help > Open live chat ( Screenshot)