Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid stores are not available on Wix websites
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been fixed. All the data (products, orders, your store settings, etc) are safe and intact. The Ecwid stores on Wix websites continue functioning as usual. We are deeply sorry for the difficulties you faced.
Posted Oct 01, 2019 - 14:57 UTC
Monitoring
A fix has been implemented. Now, Ecwid stores added on the Wix websites operate correctly. We continue to monitor the systems to ensure that everything works smoothly.
Posted Oct 01, 2019 - 14:08 UTC
Update
We continue working on a fix for this issue with the highest priority. We’re sorry for this downtime.
All your stores' data is safe and intact. We'll post the next update in one hour.
Posted Oct 01, 2019 - 12:39 UTC
Identified
Our team has identified the cause of the issue. We are urgently working on implementing the fix. We'll post the updates here.
Posted Oct 01, 2019 - 10:29 UTC
Investigating
Ecwid storefronts are not loading on Wix websites. When you open your storefront page, you can see "Service is temporarily unavailable. Please try again later" error.

We are working to get them up and running urgently.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts will be operating well as soon as the issue is fixed.

We are sorry for this downtime.
Posted Oct 01, 2019 - 07:12 UTC
This incident affected: Storefront.