Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Buyers from several countries might not be able to place orders
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 09:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2020 - 09:25 UTC
Investigating
We are having issues with some of Ecwid stores — customers from the following countries might not be able to go through the shipping step at checkout:

Germany, United Kingdom, France, Izrael, Switzerland, South Africa, the Netherlands, Portugal, Belgium, Austria, New Zealand, Poland, Romania, Norway, Pakistan, Finland, Cyprus, Denmark, Lithuania, Greece, Singapore, Croatia.

When customers from the above-mentioned countries select the shipping method, they might be not able to proceed with placing the order.
We’re working on fixing it urgently and will keep you posted here.

We are sorry for this downtime. The approximate time of when the issue is resolved is in 60 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Jul 14, 2020 - 08:30 UTC
This incident affected: Checkout.