Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and control panels are unavailable or are loading slowly
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 11:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2020 - 10:17 UTC
Investigating
Ecwid control panels and storefronts are not loading or are loading slowly:

You may see the 'We are having technical issues' error in your control panel.
And your customers can not access your store with "This page isn’t working" error.

We are urgently working on a fix.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts and control panels will be up and running once we fix the problem. Approximately 13% of store are affected by this outage.

We are very sorry for this downtime. We’ll be posting updates here.

ETA 20 minutes

If you have any questions, you can email our Support team at support@ecwid.com, or start Pre-Sales Chat: click on the chat icon on our site https://www.ecwid.com/ ( Screenshot)
Posted Jul 02, 2020 - 09:23 UTC
This incident affected: Storefront and Admin.