Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and control panels are unavailable
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 23:15 UTC
Monitoring
We were experiencing an issue with some of the servers — Ecwid Dashboards and storefronts were unavailable.

Immediately our engineers have implemented the fix. All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts and control panels are up and running now.

Now, we continue to monitor the systems to ensure that everything works smoothly.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Jun 19, 2020 - 22:26 UTC
This incident affected: Storefront and Admin.