Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and control panels are unavailable
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 05:22 UTC
Monitoring
We are experiencing an issue with some of the servers — Ecwid Dashboards and storefronts were unavailable from 03:23 to 03:40 UTC.

Immediately our engineers have implemented the fix. All your data (products, orders, customer details, store settings, etc) is safe and intact. The storefronts and control panels are up and running now.

Now, we continue to monitor the systems to ensure that everything works smoothly.

If you have any questions, you can email our Support team at support@ecwid.com
Posted Jun 08, 2020 - 03:53 UTC
This incident affected: Storefront and Admin.