Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

We are having issues with the servers: Ecwid control panels and storefronts are not loading for 32% of users.
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been fixed. All the data (products, orders, your store settings, etc) are safe and intact. The Ecwid stores continue functioning as usual. We are deeply sorry for the bad experience. We’ll do better.
Posted Nov 16, 2021 - 13:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2021 - 12:02 UTC
Monitoring
We identified the reason of the issue and applied the fix. Now all Ecwid admins and stores are operating normally.

All your data remains safe and intact. We will keep monitoring the results.
Posted Nov 16, 2021 - 11:48 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2021 - 11:39 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2021 - 11:38 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2021 - 11:37 UTC
Investigating
We are on the issue and looking for a fix. All your data is safe and intact, the stores will be operating normally as soon as the issue is fixed. We are sorry for this downtime. Next update in 10 minutes.
Posted Nov 16, 2021 - 11:35 UTC
This incident affected: Storefront, Checkout, and Admin.