Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some system emails will be delivered with a delay due to planned maintenance on January 11, from 6 a.m. to 12 p.m. UTC
Incident Report for Ecwid
Resolved
Mandrill has completed their planned maintenance. All notifications about subscription actions and staff account invitation emails are delivered without delay.

We appreciate your patience, thank you!
Posted Jan 11, 2020 - 17:48 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 11, 2020 - 17:45 UTC
Monitoring
Notifications about subscription actions and staff account invitation emails will be delivered with a delay due to planned maintenance of the service we use to send these emails — Mandrill: https://mailchimp.com/planned-mandrill-outage/ The maintenance is scheduled for January 11, from 6 a.m. to 12 p.m. UTC. All the other emails, for instance, order notifications, will be delivered normally.

During the maintenance, the service will be unavailable and the system emails won't be sent. They will be delivered after the maintenance is over.

If you want to know your subscription status, you can always check it in your Ecwid control panel->My Profile->Billing and Plans: https://my.ecwid.com/#billing

In case you need to invite a new staff member, please contact us at support@ecwid.com and we will get an invitation link you will be able to send to the person you'd like to invite.

We're sorry for the trouble caused!
Posted Jan 10, 2020 - 20:09 UTC