Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

40% of Ecwid Stores are loading slowly
Incident Report for Ecwid
Resolved
This issue has been resolved.
Posted Sep 10, 2019 - 19:10 UTC
Monitoring
The service has been restored. All Ecwid storefronts and control panels are working fine at this moment.

We are monitoring the results to make sure this outage won't happen again.

All your store data is safe and intact. Please accept our sincere apologies for this downtime.
Posted Sep 10, 2019 - 18:56 UTC
Identified
We've found the source of this issue and are working on the fix at the moment. ETA is 30 minutes.

We're very sorry for this downtime.
Posted Sep 10, 2019 - 18:44 UTC
Investigating
Ecwid is having troubles with one of the servers: about 40% of the storefronts and control panels may be loading slowly. Our engineers are already fixing the services.

All your data will be kept intact and safe. Please, accept our apologies for these troubles. We will be publishing updates here.
Posted Sep 10, 2019 - 18:35 UTC
This incident affected: Storefront, Checkout, and Admin.