Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Issues with Ecwid support chats
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted May 18, 2020 - 16:44 UTC
Investigating
At the moment we experience issues with our support chats: some users may not be able to reach our agents and some messages are very slow to load and go through. We are already working on it, we'll be posting updates here.

If you need urgent assistance please email us at support@ecwid.com, we will get back to you shortly.
Posted May 18, 2020 - 16:03 UTC