Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid forums are unavailable
Incident Report for Ecwid
Resolved
Ecwid forums are fully operational. Please accept our sincere apologies for this issue.
Posted Mar 29, 2017 - 19:49 UTC
Investigating
At the moment Ecwid forums are having problems and unavailable for all our users.

No worries about your Ecwid store: all your store data is absolutely intact and Ecwid users are able to access their Ecwid control panel as usual. This issue affects our Forums website.

Ecwid users are always able to contact the support team via Contact form.

We are very sorry for this downtime. Our engineers are working on restoring the service.
Posted Mar 29, 2017 - 19:19 UTC