Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Scheduled maintenance of Ecwid databases
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jun 16, 2016 - 05:05 UTC
Monitoring
We’re having a scheduled maintenance of our databases on June 16, from 05:00 AM to 05:10 AM UTC (click here to learn what time it is for your location). We expect the whole system to be restarted and inaccessible within 1 (one) minute: all of Ecwid storefronts and control panels may be opening slowly or not open.

We apologize for this possible downtime. Our specialists will be monitoring the system.

All data including products, orders, stores settings will be kept safe and intact. We will be posting updates here.
Posted Jun 15, 2016 - 10:23 UTC